Using WebSocket API data source with Grafana Cloud


I’m unable to use the Golioth WebSocket API plugin with Grafana Cloud.

If an invalid endpoint is entered, clicking on “Save & test” responds with “Data source is working”.

It may be that the plugin is out of date but I don’t see any upgrade option.

I also reviewe @ChrisGammell 's WebSocket API recording and tried setting up a WebSocket endpoint & a dashboard again without any success.

The JSON API as a data source works fine.

Would it be possible for you to record as you try to add the data source to your project?

We’ll show this feedback about the invalid endpoint to our WebSocket plugin developer, but that may be separate from the issue of actually being able to get a connection to Golioth working.

Hi Folks.
Thanks for posting the video, Chris. I followed it but I’m still having the same problem. Here’s a video. Hoping you see what I’m doing wrong!

@jcurran and @ChrisGammell
Thanks. It’s the same issue as what I’m seeing.

Will do.
Is the WebSocket plugin available in Grafana Cloud the same as what you used in your recording?

Did you make any progress with the WebSocket plugin? Thanks.

Hi - nope. I have not tried since I made the video. Not usual for Golioth guys to go quiet, in my experience. Wonder if they discovered something or are at a trade show.

Hi @ChrisGammell,

After further testing with Grafana support, the conclusion is that the WebSocket plugin isn’t functioning on the Grafana cloud stack. We’ve tested against open endpoint and can not return any series. Additionally, as previously mentioned, any endpoint , valid or not , tests successfully.

Grafana Support aren’t able to do anything more as the Golioth WebSocket is not a supported plugin by them.

Can you or one of your colleagues at Golioth assist? Thanks.

He folks, sorry for the radio silence on this one. I’ve just tested WebSockets with Golioth on Grafana and found it to be working. I made a quick video while I tested it, please take a look and let us know if this solves your issues:

Hi Mike.
I believe the issue is that the WebSocket plugin for Grafana Cloud doesn’t work but it works for a local Grafana installation.
Do you mind trying using Grafana Cloud and the WebSocket plugin? Thanks.

Yes, I have tested it on (I think that’s what you mean by Granafa Cloud?) and found it to be working.

If you are still having issues, can you make a video that walks through how you set it up and shows off where the issue occurs?

One important update when working with @jcurran on the issue: you must use all lower-case for x-api-key, if you use upper case the query will not authenticate.

Thanks. I was using all uppercase for the x-api-key.
I’ll re-test.

Hi @mike,

I’ve got the Grafana dashboard with the WebSocket plugin to work. Using all lowercase for “x-api-key” worked. Thank you.

It’s interesting that a dashboard with JSON API works fine using the “X-API-KEY” in uppercase.

I’m glad to hear it’s working now!

While I’m not certain, the two plugins may be using those values in different ways. Here’s a note in the documentation for one of the libraries we use in the WebSockets plugin that query string paramaters should be lower case (but header names don’t have the same restriction): Key Auth | Kong Docs